The aumhaa Website has been transported, please go here instead:

We don't hang around here anymore.....

Search This Blog


Monomod b932rc out to those who are following this:  I'll post this stuff up on when I am sure that there aren't any obvious bugs.  If you are on the mailing list, I'll send you a link to the files.  If your not on the list and you would like to be, make sure I have your email:

Additions/bugfixes/improvements to b932rc:

Plinko: fixed problem with not being able to see grid activity, problem with random restarts, restart on time change option

Gome: possible fix for note duration on first loop (not fully tested yet).

TR256: Added real-time MIDI recording functionality (press sequence play then edit to toggle: sequence edit and play will both change colors), copy/paste (press sequence edit to copy then sequence paste of the sequence you wish to paste to), clear sequence (press sequence edit then any of the mode buttons on the left), trigger sequence on timing change (see below), and trigger sequence step (press play then the step of the sequence you wish to start from).

Trigger sequence on timing change works like this: if its turned on, and you change timing, on the next downbeat it will trigger the current sequence from the beginning so that it coincides with the downbeat.  Plinko will work this way in the future, and possibly Polygome.  I want to test it out realworld for a while and see if anything needs to change with it before I spend a lot of time converting other plugs with the same functionality.

Recording hasn't been tested much, so I assume there will be issues.  Everything is quantized to the timing grid of what is currently selected.

All the copy/paste/clear functionality is sluggish.  This is due to the way in which I have had to store program data within m4l.  Sorry...its the price of being able to save and recall everything easily with each song/preset.

Boinngg and Presscafe: largely untouched, I merely updated the timing engine for them.

Please let me know if you find any problems.

Next on the agenda (besides testing these plugs) is getting a Plug together to deal with native Monome patches.  Oh, and something like "Pitches" (that shouldn't take too long, except that I'd like to figure out a way to re-inject stuff back into control_surfaces so that the plug can also control drumracks ala' external controllers).

On second thought, first order of business will be to get the [monomods] core abstract commented, so I can post it and you guys can know what is what.


  1. Apparently there is something messed up with init order for channel: I'm getting bleed-through of all Monomod channels into the viewer when I load up a Live song with a multiple monomod clients loaded, even if they are on seperate channels.

  2. checked plinko yesterday, no problems until i deleted some notes and they were still played (but not lit)

    i checked your video again and realized i was holding button 4 + pressing button 3 to delete. have to try again.

    if you gonna release it fully you need some documentation in the package.

    the top four buttons on the right are layers but they are in the same plane . is that right?

    more testing and comment later..

  3. Soon, there will be an editor window that pops up whenever you press a node. It will show all 4 planes, all of their directions and attributes at once, and you will be able to change them directly from the pop-up window.

    Docs will definitely be included. There is some info included alreay - click on the question mark inside the "0" of "Plink-O" - its the help-file.

  4. gome:

    it's not recording sequences correctly, really weird

    one sequence played only half tempo,

    it felt like there were different durations for single steps,but mode 4 is note duration, right?

    strange behaviour if 3 pads played together
    and one finger alters pad,

    hold pad in playmode switch to another mode- release pad - back to playmode ->like holds the pad

    maybe wait for some other comments, for me it is not useable at the moment

  5. gome is a toughy....have you used the original version?

    some stuff, I think, might just be the way gome works. some others are peculiar I'll grant you. I'll spend some time with it in the next couple of days...I have a particular way I use gome, so I probably wouldn't notice a lot of things if they weren't working right.

    the bit with hold pad, switch mode, come back to mode: I'm aware of it being like that if you switch to another monomod patch, but not another mode in gome. I'll see if I can fix it.

  6. @ oLsen:

    I examined the things you were refering to.

    Recording a sequence works fine for me. I think you may misunderstand how record works. It records each step sequentially, but the timing of how you play a part in has nothing to do with it. It will record the first note, as the first step, the second as the second step, etc. If you switch out of record and back into it, I think it starts over again.

    Note duration: yes, I'm getting this weirdness, also. Can't explain it, I'll have to dig into the patch. I don't think its anything I've done, I suspect its in Stretta's original patch.

    Half tempo thing: can't recreate. Is it a particular sequence number?

    Strange behaviour with 3 pads held: I need more info. What's it doing?

    Switching from play to another mode and releasing the note: again, this functions the same in the original patch. I'm not sure of an easy way around this. Its not getting the note off to that part of the patch when the play mode is not active. If you switch back to play and press that button again, it should release it.

    Polygome is a strange beast. I'm just now learning how to use certain parts of it, and I've been using it for a while. I think of it as just an eccentric instrument, and kind of work around its idiosyncracies. Have you tried Stretta's recent releases? Do they behave the same? I started porting this patch over a year ago, so he may have fixed some of the issues you speak of since then, and I merely haven't incorporated them.

  7. i think i have some problems with my system, last expirience with gome was better, but then presscafe was all messed up. it's like the output of the midi data is getting to much for my amd 1,6ghz. or higher priority processes need to much cpu. need to upgrade.

    yes i know the gome recording

    duration bug still present

    last tested it worked again with 4 sequences simultan. and the colors

    maybe we find a way to send that note off if another mode is entered

    i tryed strettas monome suite. the problem was all patches were up/down reversed with any monome emu. will check his gome again and see..

  8. @ oLsen:

    Hey man, thanks for the excellent feedback.

    1.6 single is kinda slow for this stuff in my experience. I'm running a 2core 2.1, and I still get bogged down with some of the Monomod stuff, but for the most part I'm ok.