The aumhaa Website has been transported, please go here instead:

We don't hang around here anymore.....

Search This Blog


LaunchMod for Launchpad, a new Block script, and any Virus users?

While I'm waiting for the fix from Livid for the RGB stuff, I decided to go ahead and start building the script for the LaunchPad.  It seems that hard work has paid took less than a couple of hours to get this thing going, and most of that time was spent with fixing Python errors due to the lack of decompyled 8.22 Launchpad scripts.  This just demonstrates the portability of the scripts I've already written.  I should be able to release the new Monomodular script for the Launchpad ('LaunchMod')  at the same time as the rest of the b99 scripts.

One cool thing I've been able to do is to put the Monomodular mode in a completely seperate space.  You'll be able to use the script exactly as it normally works, and by pressing User1 + User2 at the same time, enter Monomodular mode.  I think this will offer some more possibilities, since the individual User1 and User2 modes remain intact, and you can use them for whatever you were using them before.

In addition, Jay @ Livid agreed to send over a Block for me to test with, so there will be a new script available for it as soon as I receive it.  I'm going to port the Launchpad script directly over to it, and perhaps the Ohm64 script as those of you with Blocks will have a bunch of new toys to play with!

One last thing....I've discovered a serious bug with mxj's and the Virus Control plugin...I've contacted the relevant authorities (hehe), but I'm wondering if any of you out there have a Virus and are willing to test out some files and see if they can reproduce my results?



  1. hey!
    ok like i promised in the other post, i downloaded the latest builds (r2) from svn. any issues i had were small and were commented by you anyways. one thing i had on my osx machine though was a lock up freeze thing (ableton) when loading up the compiled gome 99b. however this was only once and i could not duplicate it again.

    the one script seems to be similiar if not the same in function to the one over at livid for my ohm64. did not have time to look at livids python though - is that your baby? if so i had one issue which was repeatable - i'll only bother you with it if the script was yours though, otherwise i'll send it to the guys at livid.

    i missed your last post with the virus request.
    i have a virus kb. you should still have my "real" email in case you want to send me the plug for testing. otherwise i'll send it to you again.

    hope all that made sense, i'm a bit washed out -> bedtime now.

    thanks as always,

  2. Hey Ken,

    Thanks for trying :) Yeah, I wrote the OhmModes script for Livid, and I think they have links to my older Monomodular betas over there...I'm not sure which one you're refering to. But please let me know about bugs with either, as I'm the one that will be fixing them.

    Dunno about the freeze with gome, but I get weirdness out of it sometimes too...I didn't write it, its just a port. Now that the majority of the Framework for Monomodular is done, I'm going to be spending a lot more time writing individual patches, and gome (one of my faves) is getting a major rewrite and integration with Livid's code. That bit is about half way done, but I probably won't get back to it until September. If your able to duplicate it, send me a log if you can.

    I'll definitely drop you some mail about the Virus issue....its simple to test. I've sent reports to both Cycling and Access, and though I've gotten replies, no one has been able to tell me anything (like, even if they can reproduce it).

    I'm putting the finishing touches on the bundle for OSX right now, I should have the finished versions of the scripts out tonight before bed.

    Cheers, thanks for the feedback!